Friday, January 2, 2015

Frustrating Experience with BSNL 3G Data SIM - and a workaround

I took a BSNL SIM while travelling expecting that their services were more likely to be available in most states. Unfortunately, I did not test it well in Chandigarh before leaving.

I was using a Huawei 3G E8231 dongle and it just did not connect. I tried on cell phone as well but the data connection did not happen whether 2G or 3G.

I needed BSNL connection in Rajasthan where Tata Docomo did not have their own data service. Once I reached Pune, I did not need the BSNL connection but it worked using the APN bsnllive!

However, my relief was not long. It did not connect in Goa either, except for some reason for 1 day, when it worked very well for the whole day and using the APN bsnlnet as expected.

Since then again no connection. It is frustrating to contact BSNL support on their call centre, especially while roaming.

I sent emails to the addresses mentioned on BSNL site. The messages did not bounce; however, I got no feedback at all. Curiously, the email addresses were on :)

I got a call yesterday (may be because I had visited the BSNL office in Mapusa who said that they will contact Chandigarh for help). I was told that I should try now as the problem is resolved.

However, no change in status and I cannot call back the person who had called :(

Finally, I got a person on 1503 of the Maharashtra circle who gave me the help number for Punjab. The person from the Punjab circle wasn't helpful at all and probably disconnected in the middle. I tried once again and it got disconnected again. No point in making any more effort.

I am bewildered by why did it work on two days and not on other days. Since it worked twice, it does not seem like a compatibility problem with my devices. Oh, well, fortunately, there are many more options now, which work AND who really do try to help!

I will dump the sim. A lesson learnt for a thousand rupees - a mere US$ 15 :)

Update 7th Feb 2015:

There had to be a reason why the BSNL connection worked twice. I kept thinking about the sequence of operations which might have been the reason.

I think I now know.

The default APN for bsnl is 'bsnlnet'. It did not work.
I changed the profile to 'bsnllive'.
Waited for a while.
State is now connected. Some data is sent but nothing is received.
I changed the profile back to 'bsnlnet'.
State remains connected and the 3G data connection works :)

The above steps have worked on two days now.
Why? That remains a mystery!